Call Completion Failure [pod:04]
Incident Report for Cytracom
Resolved
This incident has been resolved.
Posted 3 months ago. Aug 22, 2018 - 10:53 CDT
Monitoring
At 09:20am CST a portion of our customers were unable to complete calls. This issue was detected immediately and resolved at 09:27am CST. We are continuing to monitor the situation.
Posted 3 months ago. Aug 22, 2018 - 09:48 CDT
This incident affected: Voice Services.