Des Moines, IA - Call Completion
Incident Report for Cytracom
Resolved
As of 12:01 CST, the market has been restored and is in service. Fiber crews are still working at this time, and the carrier has not given the all clear, but we expect that shortly. We'll continue to monitor and we will inform you if anything does happen to change.
Posted almost 3 years ago. Sep 23, 2015 - 14:00 CDT
Identified
Cytracom has identified an issue affecting inbound calls to Des Moines phone numbers. The carrier has informed us of a fiber cut in the area and at this time there is no estimated time of repair.
Posted almost 3 years ago. Sep 23, 2015 - 11:08 CDT