Payment processing elevated failure rates
Incident Report for Cytracom
Resolved
Integration with the payment processor was re-established and previously failed payments have been processed. Scheduled payment processing is fully functional.
Posted Sep 22, 2021 - 09:08 CDT
Investigating
We are currently investigating elevated failure rates during payment processing. Users may receive notices by email and in the management portal that a payment method has failed or that payment processing has failed. Additionally, users may be unable to update their payment methods in the management portal at this time.

Service will not be interrupted by these failures.
Posted Sep 20, 2021 - 13:27 CDT
This incident affected: Management (Billing Services).