Intermittent failures receiving inbound calls and messages
Incident Report for Cytracom
Resolved
The underlying carrier has resolved the issue affecting inbound calls and messages.

All voice calls and messaging are functioning normally at this time.
Posted Sep 25, 2021 - 20:14 CDT
Monitoring
A portion of Cytracom customers have experienced intermittent failures receiving inbound calls and messages. We are working with the underlying carrier to resolve the issue. More information will be provided as it becomes available.

Voice calls are functioning normally at this time.
Posted Sep 25, 2021 - 16:21 CDT
This incident affected: Voice Services (Call Completion).