Degraded Internet Connectivity - Comcast Customers
Incident Report for Cytracom
Resolved
We have been notified that all voice quality issues caused by Level3/Comcast have been resolved.
Posted 7 months ago. Nov 06, 2017 - 16:13 CST
Monitoring
Comcast has confirmed that they are experiencing internet issues throughout the country. These outages are affecting many major companies including NBC, AOL, Google, Facebook, Twitter, and more. Once these outages are resolved, call quality will be restored. We will continue to monitor the situation and update this status page.
Posted 7 months ago. Nov 06, 2017 - 12:57 CST