MWI delay
Incident Report for Cytracom
Resolved
This incident has been resolved.
Posted about 1 month ago. May 16, 2019 - 16:43 CDT
Identified
There is an issue that has been found that may cause delay in MWI for certain customers. We have identified the issue and anticipate resolution by tonight.
Posted about 1 month ago. May 16, 2019 - 16:35 CDT
This incident affected: Voice Services.