Outbound Calling
Incident Report for Cytracom
Resolved
Our upstream carrier has resolved the issue previously reported this afternoon.
Posted about 1 month ago. Feb 15, 2019 - 15:56 CST
Investigating
We have identified an outbound calling issue with one of our upstream carriers. This issue has affected call completion for users dialing certain telephone numbers. We are working closely with the carrier to resolve this as soon as possible. Meanwhile, we have implemented a solution to allow the majority of the affected phone calls to complete- if you were affected, please try to call the number again.
Posted about 1 month ago. Feb 15, 2019 - 14:10 CST
This incident affected: Voice Services.