Call Completion Issues - Inbound
Incident Report for Cytracom
Resolved
Level 3 is reporting that service has been restored.
Posted over 1 year ago. Oct 04, 2016 - 11:35 CDT
Identified
Level 3 is currently experiencing a nationwide outage impacting their carrier partners, including Cytracom. This outage is causing call completion issues for some customers. We are awaiting further updates for resolution.
Posted over 1 year ago. Oct 04, 2016 - 10:25 CDT