Proposal Creation and Update Issues
Incident Report for Cytracom
Resolved
This incident has been resolved.
Posted 3 months ago. May 08, 2019 - 15:56 CDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 3 months ago. May 07, 2019 - 14:36 CDT
Identified
Third-party Proposal Tax Calculation Service issues are preventing partners from creating or updating proposals. We will provide updates as we receive them.
Posted 3 months ago. May 06, 2019 - 16:48 CDT
This incident affected: Management Portal.