Call Quality
Incident Report for Cytracom
Resolved
This incident has been resolved.
Posted 25 days ago. May 23, 2019 - 15:12 CDT
Investigating
We are currently investigating an issue causing call quality for certain customers.
Posted 25 days ago. May 23, 2019 - 11:21 CDT
This incident affected: Voice Services.