DDoS Incident
Incident Report for Cytracom
Resolved
This incident has been resolved.
Posted about 2 years ago. Mar 16, 2016 - 10:58 CDT
Monitoring
Earlier this morning we experienced a degradation of voice services due to a DDoS attack. Our provider has worked to mitigate the issue and is continuing to monitor the situation to ensure full resolution has been reached.
Posted about 2 years ago. Mar 16, 2016 - 10:14 CDT