Login failure on secure.cytracom.com
Incident Report for Cytracom
Resolved
This incident has been resolved.
Posted Dec 16, 2024 - 13:11 CST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Dec 16, 2024 - 10:19 CST
Identified
This issue has been identified and a fix put in place. Authentication are now processing normally
Posted Dec 16, 2024 - 10:18 CST
Investigating
We are investigating issues with new logins to secure.cytracom.com. Existing authenticated users are not impacted.
Posted Dec 16, 2024 - 10:06 CST
This incident affected: Management (Management Portal) and Client Applications (Desktop, Cytracom iOS, Cytracom Android).