UCaaS: Inbound calls failing for subset of customers

Incident Report for Cytracom

Resolved

The problem has been resolved. All incoming calls are working as usual.
Posted Nov 06, 2025 - 17:17 CST

Identified

The issue has been identified and we applied a fix. We are currently monitoring incoming call completion.
Posted Nov 06, 2025 - 17:14 CST

Investigating

Some users informed that missing audio on inbound calls and the engineering team is investigating the root cause.
Posted Nov 06, 2025 - 16:45 CST
This incident affected: Voice Services (Call Completion).