UCaaS Degraded Performance
Incident Report for Cytracom
Resolved
This incident has been mitigated and resolved.
Posted Apr 22, 2024 - 15:36 CDT
Monitoring
We have identified and mitigated an issue impacting the UCaaS product. We are monitoring the results.
Posted Apr 22, 2024 - 15:17 CDT
This incident affected: Voice Services (Call Completion, Call Center).