The root cause of the billing services issue has been resolved by our upstream provider. At this time, all billing-related functions appear to be operating normally.
Posted Jun 12, 2024 - 18:57 CDT
Update
Our billing system provider is actively working on the issue. We will keep a close watch on the situation and provide updates as new information becomes available. Please reach out to your partner account manager for any urgent ControlOne orders.
Posted Jun 12, 2024 - 17:23 CDT
Update
We are continuing to experience service degradation due to issues with our billing system provider. We will continue to monitor the situation closely and provide further updates as we receive more information.
Posted Jun 12, 2024 - 13:37 CDT
Identified
An upstream provider is currently experiencing a service degradation. Cytracom ControlOne customers may see issues managing licenses or processing payments.
Posted Jun 12, 2024 - 10:11 CDT
This incident affected: Management (Billing Services).