UCaaS Fax Completion Outage

Incident Report for Cytracom

Resolved

This incident has been resolved.
Posted Jun 12, 2025 - 17:15 CDT

Monitoring

We have been informed by our third-party provider, powered by GCP, that fax services are beginning to recover. Please note that previously enqueued faxes may still experience some delays in delivery.

Our team will continue to closely monitor the situation and will issue an all-clear notification once full service has been confirmed.
Posted Jun 12, 2025 - 16:43 CDT

Identified

We have identified an issue impacting Cytracom UCaaS customers utilizing fax completion. This is a failure within a third-party component powered by GCP, which is experiencing a widespread outage. We will provide updates as they become available.
Posted Jun 12, 2025 - 14:49 CDT
This incident affected: Fax Services (Fax Completion).