Cytracom Desktop Degraded Performance

Incident Report for Cytracom

Resolved

This incident has been resolved.
Posted May 09, 2025 - 23:21 CDT

Update

We are continuing to monitor for any further issues.
Posted May 09, 2025 - 17:19 CDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 09, 2025 - 17:19 CDT

Identified

We have identified an issue causing a degraded experience for users of the Cytracom Desktop application. Our engineers are implementing a fix.
Posted May 09, 2025 - 17:10 CDT
This incident affected: Client Applications (Desktop).