This incident is marked as resolved. No further inbound call failures were observed.
Posted May 29, 2026 - 03:19 CDT
Update
We are continuing to monitor for any further issues.
Posted May 28, 2026 - 11:58 CDT
Monitoring
We have identified and mitigated an issue that was causing intermittent call completion failures.
The issue was related to a third-party CNAM lookup service responding slower than expected. This delay caused some calls to fail over to our secondary data center, which resulted in intermittent disruption to call completion.
We have temporarily disabled this dependency, and calls are now completing as expected. We are continuing to monitor call completion and overall service stability.
Posted May 28, 2026 - 11:47 CDT
Identified
The UCaaS platform is experiencing intermittent inbound/outbound call failures. We are investigating the root cause.
Posted May 28, 2026 - 10:20 CDT
This incident affected: Voice Services (Call Completion).