Fax Portal Outage

Incident Report for Cytracom

Resolved

This incident has been resolved.
Posted Jul 09, 2024 - 11:58 CDT

Update

We are continuing to monitor for any further issues.
Posted Jul 09, 2024 - 10:50 CDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 09, 2024 - 10:23 CDT

Identified

We have identified an issue with our upstream fax provider. Inbound and outbound fax services are operational, but users are unable to access the cFax portal.

We appreciate your continued patience while we worked to resolve this issue.
Posted Jul 09, 2024 - 08:45 CDT
This incident affected: Fax Services (Desktop Fax).