Call Center Duplicate Calls

Incident Report for Cytracom

Resolved

This incident has been resolved.
Posted Sep 28, 2023 - 15:55 CDT

Update

We are continuing to monitor for any further issues.
Posted Sep 28, 2023 - 10:10 CDT

Monitoring

A fix has been implemented, call center behavior has returned to normal, and we are monitoring the results.
Posted Sep 28, 2023 - 10:08 CDT

Investigating

Cytracom Engineering has identified an issue where multiple instances of the same queue call will ring through. The problem does not affect the ability to answer the queue call. We are investigating the root cause and working to a full resolution. As updates become available, they will be posted here.
Posted Sep 28, 2023 - 09:49 CDT
This incident affected: Voice Services (Call Center).