UCaaS: Intermittent Call Audio Issue

Incident Report for Cytracom

Identified

We have identified the source of intermittent inbound call drops affecting a subset of customers. Our upstream voice carrier has confirmed a network incident causing packet loss on a portion of voice traffic. This is resulting in inbound calls intermittently failing to ring through or dropping shortly after connection.

Our carrier is actively working to restore normal calling behavior, and we are closely monitoring call quality across affected accounts. We will provide updates as we have more information.
Posted Sep 02, 2026 - 14:58 CDT

Update

We are continuing to investigate this issue.
Posted Sep 02, 2026 - 14:08 CDT

Update

We are continuing to investigate this issue.
Posted Sep 02, 2026 - 13:49 CDT

Investigating

We are currently investigating an issue affecting inbound calls for some customers.

The disruption is related to a fiber network failure impacting one of our upstream service providers. Our team is actively working with the provider to monitor recovery and restore normal inbound calling as quickly as possible.

Outbound calling (unless routed through this provider) and other services are not currently impacted.

We will provide additional updates as more information becomes available.
Posted Sep 02, 2026 - 13:48 CDT
This incident affects: Voice Services (Call Completion).