Delayed Email Notifications
Incident Report for Cytracom
Resolved
Delivery of email alerts, including voicemail notifications and password resets for all services have returned to normal.
Posted Feb 03, 2023 - 12:44 CST
Monitoring
Our email provider has identified the issue and is working on processing the backlog of outbound emails. There may continue to be delays in receipt of email alerts at this time, but that delay will progressively improve as the queue is completed.
Posted Feb 03, 2023 - 12:39 CST
Investigating
Our email provider is currently experiencing difficulties with outbound delivery, and all email alerts, including voicemail notifications and password resets for all services may be delayed. Please check back for updates.
Posted Feb 03, 2023 - 12:29 CST
This incident affected: Integrations.