Some Spectrum customers are unable to make or receive calls

Incident Report for Cytracom

Resolved

Call completion rates from Spectrum broadband customers has returned to normal levels. Upstream peering from Spectrum has been confirmed to be restored from multiple points of observation.

This incident has been resolved.
Posted Jun 08, 2022 - 18:32 CDT

Investigating

We are currently investigating a regional issue affecting call completion for customers of Spectrum broadband.
Posted Jun 08, 2022 - 16:44 CDT
This incident affected: Voice Services (Call Completion).