Unable to make outbound calls from Cytracom Web App on latest Chrome update
Incident Report for Cytracom
Resolved
We have resolved an issue preventing users from making calls from Google Chrome version 96.0.4664.55.
Posted Nov 19, 2021 - 17:02 CST
Identified
We have identified an issue on Chrome version 96.0.4664.55, that prevents users from being able to make outbound calls on Cytracom Desktop. Users are still able to receive calls and use Business Messaging. To make outbound calls, please use Cytracom Mobile or the Cytracom Desktop App.

We are currently working to address this issue, and will post an update if there is a change in service.
Posted Nov 19, 2021 - 13:13 CST
This incident affected: Client Applications (Desktop).