UCaaS: Inbound Call Failures Impacting Subset of Customers

Incident Report for Cytracom

Resolved

All inbound calls are working.
Posted Mar 03, 2026 - 10:21 CST

Update

We are continuing to monitor for any further issues.
Posted Mar 03, 2026 - 09:17 CST

Monitoring

We identified an issue with our connecting carrier affecting inbound calls. The carrier has deployed a fix, and inbound calls are now functioning normally.
Posted Mar 03, 2026 - 09:04 CST

Update

We are continuing to investigate this issue.
Posted Mar 03, 2026 - 08:38 CST

Investigating

We are currently investigating a higher number of inbound call failures that may impact subset our customers.
Posted Mar 03, 2026 - 08:37 CST
This incident affected: Voice Services (Call Completion).