UCaaS: Intermittent Inbound / Outbound Call Failures

Incident Report for Cytracom

Resolved

This issue has been resolved.
Posted Mar 06, 2026 - 16:24 CST

Update

We are continuing to monitor for any further issues.
Posted Mar 06, 2026 - 15:54 CST

Monitoring

From our monitoring and telemetry data the issue appears to be resolved and call completion rates are in the normal range.
Posted Mar 06, 2026 - 15:52 CST

Update

We are continue to investigate the issue.
Posted Mar 06, 2026 - 15:23 CST

Investigating

Some of the inbound / outbound calls from our system experiencing intermittent failures. We are currently trying to identify the root cause.
Posted Mar 06, 2026 - 14:46 CST
This incident affected: Voice Services (Call Completion).