Faxes are unavailable within Cytracom Desktop
Incident Report for Cytracom
Resolved
This incident has been resolved.
Posted Oct 29, 2021 - 17:01 CDT
Update
A fix has been implemented and we are monitoring the results.
Posted Oct 29, 2021 - 16:28 CDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 29, 2021 - 16:19 CDT
Update
We have identified what is preventing fax retrieval within Cytracom Desktop and are actively working to address this issue.

While we are working on a fix, fax services will be temporarily unavailable within Cytracom Desktop. In the mean time, if you need to send a fax or view your fax history, please visit: https://secure.cytracom.net/documo-fax
Posted Oct 29, 2021 - 13:09 CDT
Identified
An issue preventing fax retrieval has been identified within Cytracom Desktop.

Faxes are still being received at this time. We will post an update if there is a change in service.
Posted Oct 29, 2021 - 10:31 CDT
This incident affected: Fax Services (Desktop Fax).