Partial Service Degradation for Agents in the US-Midwest (ORD) Region

Incident Report for Cytracom

Resolved

This incident has been resolved.
Posted Mar 22, 2025 - 07:36 CDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 21, 2025 - 16:17 CDT

Investigating

We have identified an issue impacting ControlOne Agents within the US-Midwest (ORD) region. Our engineers are actively working on a fix.
Posted Mar 21, 2025 - 15:27 CDT
This incident affected: ControlOne Routing Services (US-MidWest (ORD) Region).