UCaaS: Partial Inbound/Outbound Call Failures

Incident Report for Cytracom

Resolved

The issue causing partial inbound and outbound call failures has been resolved.

Corrective action was taken by restarting a small number of call processing servers, which restored normal call flow. After continued monitoring, inbound and outbound calling have remained stable.

Some customers may have experienced failed call attempts, delayed call setup, or intermittent call completion issues during the incident window.

We apologize for the disruption and appreciate your patience while our team worked to restore service.
Posted Jul 07, 2026 - 16:48 CDT

Monitoring

We have taken corrective action to address the partial inbound and outbound call failures affecting some customers.

A small number of call processing servers were restarted to restore normal call flow. Call traffic has recovered, and we are currently monitoring the platform to confirm continued stability.

Some users may have experienced failed call attempts, delayed call setup, or intermittent call completion issues during the incident.

We will continue monitoring and provide a final update once the issue is fully resolved.
Posted Jul 07, 2026 - 12:35 CDT

Investigating

We are currently investigating an issue causing partial inbound and outbound call failures for some customers.

Affected users may experience failed call attempts, delayed call setup, or intermittent call completion issues. The issue does not appear to impact all calls or all customers.

Our engineering team is actively investigating and working to restore full calling functionality. We will provide additional updates as more information becomes available.
Posted Jul 07, 2026 - 12:17 CDT
This incident affected: Voice Services (Call Completion, BLF Presence).