UCaaS: Voice Traffic Impacted

Incident Report for Cytracom

Resolved

Resolved: The upstream routing issue appears resolved. Call completion is operating within normal thresholds. Root cause is under investigation.
Posted Mar 25, 2026 - 13:35 CDT

Monitoring

The upstream routing issue has been resolved. We are observing normal call completion rates across affected routes.
Posted Mar 25, 2026 - 13:05 CDT

Investigating

We are experiencing intermittent network disruptions impacting call completion. We are currently investigating the issue.
Posted Mar 25, 2026 - 12:59 CDT
This incident affected: Voice Services (Call Completion).