Outbound Fax Delays
Incident Report for Cytracom
Resolved
Our vendor has resolved the outbound fax delay issue. All systems are operational.
Posted Oct 25, 2023 - 13:46 CDT
Monitoring
Our vendor has implemented a fix and we are monitoring the results.
Posted Oct 25, 2023 - 08:41 CDT
Identified
We have identified an issue with our upstream fax provider who is investigating an issue causing delays in sending outbound faxes. Please check back for updates.
Posted Oct 24, 2023 - 15:30 CDT
This incident affected: Fax Services (Fax Completion, Desktop Fax).