All Cytracom subscribers are able to successfully make and receive calls from all extensions, hardware phones, and applications. We will continue to monitor call completion rates and will provide an update if there is a change in status or service level.
Posted Sep 25, 2023 - 02:00 CDT
Update
As of the last update, a subset of accounts using some cordless models were identified as being unable to reliably complete calls. A fix was implemented for this issue.
Additionally, customers with recently updated IVRs or other system recordings may have been subjected to call failures. Service for all IVR customers have been fully restored.
At this time, call completion rates have returned to normal levels. All Cytracom subscribers are able to complete inbound and outbound calls.
As a reminder, please refer to our published firewall best practices to ensure connectivity to Cytracom’s redundant data centers.
Posted Sep 24, 2023 - 18:21 CDT
Monitoring
Cytracom Engineering has put a fix in place, and we are monitoring the results.
Posted Sep 24, 2023 - 12:46 CDT
Update
Cytracom Engineering has restored call functionality to users making calls through desktop phones. The mobile app's status of working has remained unchanged. Currently, we are investigating call completion through Cytracom Desktop. Updates will be posted here.
Posted Sep 24, 2023 - 10:56 CDT
Update
We are continuing to investigate this issue.
Posted Sep 24, 2023 - 09:36 CDT
Investigating
Cytracom Engineering has identified an issue impairing voice services for our customers on the desktop phone and our desktop app. Calls on the mobile app are working at this time. We are investigating the root cause and working to a full resolution. As updates become available, they will be posted here.
Posted Sep 24, 2023 - 09:13 CDT
This incident affected: Voice Services (Call Completion).