Intermittent failures loading messages within Cytracom Desktop + Mobile
Incident Report for Cytracom
Resolved
This incident has been resolved.
Posted Nov 21, 2022 - 14:05 CST
Investigating
We are currently investigating an issue affecting messages within Cytracom Desktop and Mobile apps.

The ability to make and receive calls is not affected at this time.
Posted Nov 21, 2022 - 11:36 CST
This incident affected: Business Messaging.