UCaaS: Caller ID Name Resolution

Incident Report for Cytracom

Resolved

The CNAM (Caller ID) service is fully functional without any performance constraints.
Posted May 29, 2026 - 18:27 CDT

Monitoring

The Caller Id resolution is working as expected. We are monitoring for any further issues.
Posted May 29, 2026 - 16:02 CDT

Identified

We have identified that our third-party CNAM provider is not responding within our required performance thresholds. To prevent call completion delays or failures, we are temporarily bypassing Caller ID name resolution for affected calls.

During this time, calls may complete without a resolved caller identity or display name. Call delivery itself remains operational.

Our team is working on a remediation plan and expects to implement a permanent solution within the next 72 hours. We will continue to monitor the service and provide updates as progress is made.
Posted May 29, 2026 - 13:41 CDT
This incident affected: Voice Services (Caller ID Resolution, SpamGuard Service).