UCaaS Voice Services Impairment from a subset of ISPs

Incident Report for Cytracom

Resolved

This incident has been resolved.
Posted Nov 14, 2025 - 21:43 CST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Nov 14, 2025 - 16:02 CST

Investigating

Cytracom Engineering has identified an issue impairing voice services for a subset of our customers. We are investigating the root cause and working towards a full resolution. As updates become available, they will be posted here.
Posted Nov 14, 2025 - 13:01 CST
This incident affected: Voice Services (Call Completion).