UCaaS: Desktop App

Incident Report for Cytracom

Resolved

This incident has been resolved.
Posted Apr 07, 2026 - 16:13 CDT

Update

We are continuing to monitor for any further issues.
Posted Apr 07, 2026 - 11:22 CDT

Monitoring

Some customers reported issues with inbound and outbound calls on the Desktop App. Affected users were advised to log out and log back in to resolve the issue.
Posted Apr 07, 2026 - 11:22 CDT
This incident affected: Voice Services (Call Completion) and Client Applications (Desktop).