UCaaS Partial Outage

Incident Report for Cytracom

Resolved

This incident has now been resolved. All systems are fully operational.
Posted Feb 13, 2025 - 13:05 CST

Update

We are continuing to monitor for any further issues.
Posted Feb 13, 2025 - 10:40 CST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 13, 2025 - 10:33 CST

Update

Some customers may experience delays when making or receiving calls. Call Center for affected customers will require the agent user to log out and back into the queue.
Posted Feb 13, 2025 - 10:03 CST

Update

We are continuing to work on a fix for this issue.
Posted Feb 13, 2025 - 09:14 CST

Identified

We have identified the cause of a short interruption to UCaaS services and are investigating.
Posted Feb 13, 2025 - 08:32 CST
This incident affected: Voice Services (Call Completion) and Client Applications (Desktop, Cytracom iOS, Cytracom Android).