UCaaS: Partial Inbound Call Failure

Incident Report for Cytracom

Resolved

This issue has been resolved. A fix was implemented for the call routing node failure, and inbound and outbound call completion are now functioning correctly.
Posted Mar 20, 2026 - 09:53 CDT

Monitoring

A fix has been implemented for the call routing node failure. Inbound and outbound call completion are now functioning correctly.
Posted Mar 20, 2026 - 09:35 CDT

Investigating

We are experiencing partial inbound/outbound call failures. We are currently investigating.
Posted Mar 20, 2026 - 08:59 CDT
This incident affected: Voice Services (Call Completion).